Ubuntu Installation Instructions

Warning

If you want to install the bleeding-edge or development version of Theano from GitHub, please make sure you are reading the latest version of this page.

Requirements

Note

We only support the installation of the requirements through conda.

Python == 2.7* or ( >= 3.4 and < 3.6 )
The development package (python-dev or python-devel on most Linux distributions) is recommended (see just below). Python 2.4 was supported up to and including the release 0.6. Python 2.6 was supported up to and including the release 0.8.2. Python 3.3 was supported up to and including release 0.9.
NumPy >= 1.9.1 <= 1.12
Earlier versions could work, but we don’t test it.
SciPy >= 0.14 < 0.17.1
Only currently required for sparse matrix and special functions support, but highly recommended. SciPy >=0.8 could work, but earlier versions have known bugs with sparse matrices.
BLAS installation (with Level 3 functionality)
  • Recommended: MKL, which is free through Conda with mkl-service package.
  • Alternatively, we suggest to install OpenBLAS, with the development headers (-dev, -devel, depending on your Linux distribution).

Optional requirements

python-dev, g++ >= 4.2
Highly recommended. Theano can fall back on a NumPy-based Python execution model, but a C compiler allows for vastly faster execution.
nose >= 1.3.0
Recommended, to run Theano’s test-suite.
Sphinx >= 0.5.1, pygments
For building the documentation. LaTeX and dvipng are also necessary for math to show up as images.
pydot-ng
To handle large picture for gif/images.
NVIDIA CUDA drivers and SDK
Highly recommended Required for GPU code generation/execution on NVIDIA gpus. See instruction below.
libgpuarray
Required for GPU/CPU code generation on CUDA and OpenCL devices (see: GpuArray Backend).
pycuda and skcuda
Required for some extra operations on the GPU like fft and solvers. We use them to wrap cufft and cusolver. Quick install pip install pycuda scikit-cuda. For cuda 8, the dev version of skcuda (will be released as 0.5.2) is needed for cusolver: pip install pycuda; pip install git+https://github.com/lebedov/scikit-cuda.git#egg=scikit-cuda.
warp-ctc
Required for Theano CTC implementation. It is faster then using an equivalent graph of Theano ops.

Installation

Stable Installation

With conda

If you use conda, you can directly install both theano and pygpu. Libgpuarray will be automatically installed as a dependency of pygpu.

conda install theano pygpu

Warning

Latest conda packages for theano (>= 0.9) and pygpu (>= 0.6*) currently don’t support Python 3.4 branch.

With pip

If you use pip, you have to install Theano and libgpuarray separately.

theano

Install the latest stable version of Theano with:

<sudo> pip install <--user> Theano[test, doc]
  • Any argument between <...> is optional.
  • Use sudo for a root installation.
  • Use user for a user installation without admin rights. It will install Theano in your local site-packages.
  • [test] will install the requirements for testing.
  • [doc] will install the requirements in order to generate the documentation.

If you encountered any trouble, head to the Troubleshooting page.

The latest stable version of Theano is 0.9.0 (tagged with rel-0.9.0).

libgpuarray

For the stable version of Theano you need a specific version of libgpuarray, that has been tagged v0.6.9. Download it with:

git clone https://github.com/Theano/libgpuarray.git
cd libgpuarray
git checkout tags/v0.6.5 -b v0.6.9

and then follow the Step-by-step instructions.

Developer Installation

Install the developer version of Theano with:

git clone git://github.com/Theano/Theano.git
cd Theano
<sudo> pip install <--user> <--no-deps> -e .
  • Any argument between <...> is optional.
  • Use sudo for a root installation.
  • Use user for a user installation without admin rights. It will install Theano in your local site-packages.
  • Use no-deps when you don’t want the dependencies of Theano to be installed through pip. This is important when they have already been installed as system packages.
  • -e makes your installation editable, i.e., it links it to your source directory.

If you encountered any trouble, head to the Troubleshooting page.

libgpuarray

See instructions for bleeding-edge installation about libgpuarray.

Manual Openblas installation (deprecated)

The openblas included in some older Ubuntu version is limited to 2 threads. Ubuntu 14.04 do not have this limit. If you want to use more cores at the same time, you will need to compile it yourself. Here is some code that will help you.

# remove openblas if you installed it
sudo apt-get remove libopenblas-base
# Download the development version of OpenBLAS
git clone git://github.com/xianyi/OpenBLAS
cd OpenBLAS
make FC=gfortran
sudo make PREFIX=/usr/local/ install
# Tell Theano to use OpenBLAS.
# This works only for the current user.
# Each Theano user on that computer should run that line.
echo -e "\n[blas]\nldflags = -lopenblas\n" >> ~/.theanorc